My case against camelCase


I haven't been thinking much about how I name my variables. I was just flowing with the community or sometimes using the conversion already applied in the codebase am working on. When writing Python, I usually use snake_case and when writing JavaScript, it's mostly camelCase as it is the most common naming conversion in the JS community.

Personally, I find camelCase a bad naming conversion; simply because it slows me down when reading code. It's just hard to read WordsWhichAreTiedTogether.

It's easier to read display_values than to read displayValues.

When browsing through a huge codebase and trying to understand how the code works; snake_case will make things better. That's why we have spaces between every word in our English grammar, it improves readability.